Как изменить шрифт в терминале сервера?

Я запустил сервер 10.04 дома. Можно ли установить новый шрифт в Ubuntu 10.10 используется в настольных версиях на мой сервер и настроить его так, чтобы консоль использует его, когда я подключить к нему монитор, когда я работаю на нем (за что SSH не работает)?

Спасибо за вашу помощь!!

+973
500865 6 июн. 2011 г., 6:10:23
26 ответов

У меня есть картридж HP B210 это е-печатать принтер с возможностью печати по WiFi, я использую этот принтер в Google облако печати, однако есть и обратная сторона медали, программное обеспечение, которое поставляется с это только для Windows, так что я использую свой Android устройства.

Передача файла на моем телефоне, потом с помощью приложения HP и облачных приложений для печати отправить задание на принтер, который, честно говоря, не так сложно, но я чувствую, что я делаю больше шагов, чем нужно.

Итак, есть ли способ, чтобы установить принтер в Ubuntu или есть 3-й партии приложение, в котором я мог бы просто импортировать/перетащите вакансии в службы Google и напечатать их?.

+913
herdingofthecats 03 февр. '09 в 4:24

Там не достаточно информации, чтобы точно знать, чего вы желаете, а я постараюсь угадать, и это может помочь. Если у вас файл называется cities.txt в котором содержатся:

ХХ
ГОРОД-ИЗ-ТЕКСТОВОГО-ФАЙЛА СТРОКИ-1
Калифорния
Калифорния
ХХ

а потом ты побежал на awk команду на этот вход:

на awk 'начало{печати "<сс:сс строка:высота =\"22\">"}{е " <ПС:ячейки>\п <сс:сс данные:Тип=\"строка\">%х</ПС:данных>\п </ПС:ячейки>\П",$0}конец{печать "</ПС:строки>"}' < cities.txt

затем вам следует вывод:

<сс:сс строка:высота ="22">
<СС:ячейка>
 <сс:сс данные:Тип="строка">ХХ</ПС:данные>
</ПС:ячейки>
<СС:ячейка>
 <сс:сс данные:Тип="строка">города-из-текстового-файла строки-1</ПС:данные>
</ПС:ячейки>
<СС:ячейка>
 <сс:сс данные:Тип="строка">Калифорния</ПС:данные>
</ПС:ячейки>
<СС:ячейка>
 <сс:сс данные:Тип="строка">Калифорния</ПС:данные>
</ПС:ячейки>
<СС:ячейка>
 <сс:сс данные:Тип="строка">ХХ</ПС:данные>
</ПС:ячейки>
</ПС:строки>

Это не может ответить на ваш запрос сразу, но надеюсь вам один из возможных путей (из многих), чтобы получить ваш начал.

+910
Aiden Whittaker 10 авг. 2017 г., 17:53:45

Я использовал несколько мониторов для нескольких платформ (дебиан, Убунту, в Gentoo и Fedora) с NVIDIA и ATI. Покуда видеокарта совместимая меня никогда не было каких-либо серьезных проблем с использованием различных разрешений для разных мониторов.

Незначительные проблемы с фоновыми изображениями, которые охватывают более чем один монитор, но сейчас я обычно установить фоновое изображение с азотом, и пока не охватывают изображения на несколько мониторов, никаких проблем.

У вас возникли проблемы с 12.04 ?

+833
AhmedShaban 13 дек. 2017 г., 2:34:02

epub в PDF конвертер

Прежде чем пытаться Калибр, я на самом деле конвертировать мой файл, используя вышеуказанную программу, в командной строке epub в PDF конвертер, который на самом деле является хорошим с некоторых удобных опций.

Использование:

1) распаковать архив в удобное место, и перейдите в папку разархивировали в терминале

2) сделать .исполняемый файл SH

 чмод +х ./epub2pdf.sh 

3) запустите файл

 ./epub2pdf.sh <путь-к-epub-файл>

По умолчанию выходной каталог - домашняя папка, но много настроек доступно через свойства файла, где его можно изменить.

Хотя программа не обновлялась, она работает очень хорошо, и я думал, что это может быть возможностью для людей, чтобы попробовать для преобразования их в формат EPUB в PDF.

+757
John Washington 20 дек. 2012 г., 18:52:45

Я пытался решить проблему давным-давно с моим звуком, удалив алса/puleaudio и повторная вещи, которые я не понимаю.

Теперь мой звук перепутались. Клавиши громкости на клавиатуре не работают, и я не получаю такое же меню звуковая индикация как я привык, что имел в Rhythmbox и т. д. В нем.

Кроме того, это происходит

гном-объем-управления-апплет: команда не найдена

Я очень уверен, что это просто вопрос заново АПТ-получать посылки, и возможно удаление, но я не знаю, какой.

Сам звук играет.

+705
Twilexia 13 мар. 2010 г., 18:06:12

Убедитесь, что дискета в приводе или еще нечего монтировать! Не судо горе , иначе вы можете только получить доступ с привилегиями суперпользователя.

Во-первых, чтобы увидеть диск информацию, запустить ДФ.

На моей системе С один HD дискеты появляется как СДБ (ПДД был жесткий диск)

Затем на гору:

udisks --смонтировать /dev/СКБ --горе-fstype ключевое=для vfat

е.г:

Фред@Ubuntu1:~$ udisks --смонтировать /dev/СКБ --горе-fstype ключевое=и vfat
Установленная /орг/freedesktop/UDisks/устройств/SDB в /СМИ/MM259_32BIT
Фред@Ubuntu1:~$ ДФ
Файловая система 1К-блоков использовано доступно использования% установленной на
на /dev/sda1, поскольку 152030356 9315352 134992252 7% /
в udev 890692 4 890688 1% /Дев
файловая система tmpfs 360384 856 359528 1% /запуск
никто 5120 0 5120 0% /запуск/блокировка
никто 900956 292 900664 1% /работа/ГИМ
в /dev/СКБ 1424 1397 27 99% /медиа/MM259_32BIT
+696
Giuseppe Prato 28 мая 2019 г., 0:22:42

Ок, я решил эту проблему, что Либре офис не работает после того, как я обновил до Ubuntu 12.04.

Этот вопрос был отмечен как замены на данный вопрос: не могу установить LibreOffice - однако этот вопрос содержит информацию, которая имеет жизненно важное значение для решения проблем, по крайней мере, это было для меня, так что... возможно, обозначит вопросы как дубликаты и убедившись, что информация в санкционированных и выбранный вопрос должен быть здесь политика?

Во всяком случае, я начал с Либре от ППА в Ubuntu 10.04 (у меня бы не было, если бы я знал, то был такой ажиотаж, так что моя цель при попытке решить эту проблему, в первую очередь, чтобы получить Либре на работу, а во-вторых, чтобы заставить его работать без каких-либо НПА:с, независимо от версии Либре).

Мой первый симптом, который было сломано что-то было, когда я попытался открыть документ и Либре разбился и Ubuntu хотел сделать отчет об ошибке.

Тогда я начал пытаться переустановить/установить Либре, но получил ошибки на темы:

Следующие пакеты имеют неудовлетворенные зависимости:
 в LibreOffice : зависит: блаблабла!*# но он не будет установлен
 Зависит: ... но он не будет установлен

К сожалению, я перезагрузил мой компьютер, прежде чем я думал, чтобы сохранить точное сообщение об ошибке.

Я начал путем удаления всех НПА:с (на самом деле я впервые попробовала много из них, но это не помогло).

Затем я обновил и обновлены до последней версии вещей:

судо apt-получить обновление && судо apt-получить обновление

Я тоже побежал autoremove:

судо apt-получить autoremove

Когда еще не в состоянии установить, Я удалил LibreOffice в качестве полностью, как только мог.

Я сделал это, открыв менеджер пакетов Synaptic, а затем поиск в LibreOffice и все удаления (пометить для удаления), что, казалось, ничего с Либре делать.

Разметки в LibreOffice-ядро для удаления, кажется, заботиться о большинстве из пакетов.

Я думаю, я мог бы использовать команду sudo apt-получить удалить --продувка в LibreOffice-ядра , а также, но я не делал этого, чтобы получить этот точный результат - попробуйте его, если вы чувствуете экспериментальных...

Далее я сделал еще один запуск обновления, модернизации и autoremove, как указано выше, просто чтобы быть уверенным. Однако у меня еще есть следующая проблема:

$ судо apt-получить установки LibreOffice в LibreOffice-гном
Чтение списков пакетов... готово
Построение дерева зависимостей 
Чтение информации о состоянии... готово
Некоторые пакеты невозможно установить. Это может означать, что у вас есть
просите невозможного, или если вы используете нестабильный
распределение, что некоторые необходимые пакеты еще не созданы
или были удалены из incoming.
Следующая информация может помочь разрешить ситуацию:

Следующие пакеты имеют неудовлетворенные зависимости:
 в LibreOffice : зависит: LibreOffice-внешний сердечник (= 1:3.5.4-0ubuntu1.1) но он не будет установлен
 Зависит: LibreOffice-внешний писатель, но он не будет установлен
 Зависит: LibreOffice с-Кальк, но он не будет установлен
 Зависит: LibreOffice-внешний прикид, но он не будет установлен
 Зависит: LibreOffice-внешний ничьей, но он не будет установлен
 Зависит: LibreOffice-внешний математике, но он не будет установлен
 Зависит: LibreOffice в базу, но он не будет установлен
 Зависит: LibreOffice-внешний фильтр-mobiledev но он не будет установлен
 Зависит: LibreOffice-внешний Ява-часто (>= 1:3.5.4~) но он не будет установлен
 в LibreOffice-в GNOME : зависит: LibreOffice-внешний сердечник (= 1:3.5.4-0ubuntu1.1) но он не будет установлен
 Зависит: LibreOffice-внешний ГТК, но он не будет установлен
Е: не удалось исправить ошибки, у вас прошла сломанные пакеты.

Вопрос, якобы, был заменен на этот вопрос ( не могу установить LibreOffice ) упоминает пакет libexttextcat-сведения и что это вызывает проблемы.

Что и основных текст вы провели сломанные пакеты в выше сообщение об ошибке подтолкнуло меня, чтобы попытаться удалить все пакеты Либре я смог найти (не исключено, что "сломанные пакеты" текст всегда есть и то, что заставило меня снять Либре с самого начала, однако я вовсе не уверен, что "держал" пакет .... звучит для меня, как что-то Линкольна началась бы гражданская война за...)

Одно из моих первых сообщений об ошибке, упомянутых что-то вроде этого название пакета, но это уже не в тексте ошибки, как вы его видите выше. Во всяком случае, я начал синаптической, искали libexttextcat и удалить этот пакет.

Затем я сделал некоторые обновления, обновления, autoremove (только по-настоящему "тереть грязь"...)

судо apt-получить обновление && судо apt-получить обновление
судо apt-получить autoremove

Затем я попытался снова переустановить Либре:

суда apt-получить установки LibreOffice LibreOffice будет-гном

И вот, он сделал установить и, похоже, открывать документы просто отлично.

Какая версия это? Я действительно не дают пр*п о версиях пока все работает, но как бы она, эта версия 3.5.4.2 (думаю последний стабильный от людей с Ubuntu...)

Итак, подведем итоги:

  1. Удалить любые Либре ППА:с
  2. Полностью удалить офис Либре (но только "отметить для удаления", иначе настройки будут также удалены)
  3. Удалить "libexttextcat-данные пакета" (или любой другой пакет, который был указан в начале сообщения об ошибке)
  4. Обновление, обновления, Autoremove (нахрена делать это часто! - Хм, И когда я перезагрузки моя система, а так... но это было до того как я удалил Либре, если вы хотите, чтобы перезагрузить это сделать на этом шаге, но я не думаю, что это нужно...)
  5. Установка Либре

Как Примечание стороны, я мог бы упомянуть, что я сделал это без использования предложенного "точный-предложил" выше. Я думаю, это было тогда, когда Либр не был в dist или когда вы хотите новый buggiest версии Либре или что-то...

+673
vizor01 5 мая 2010 г., 21:54:12

вы пытаетесь установить Ubuntu через wubi, так и внутри Windows? чем у меня плохие новости для вас, он, вероятно, не работает в Windows 8 (Проверить ответ на этот вопрос). попробуйте загрузиться с живого CD/DVD, создать отдельный раздел для Ubuntu и установить его там. здесь больше информации об установке Ubuntu на машину с UEFI (который является, вероятно, случае с Windows 9 компьютер)

+672
CnaPTaHeLL 28 нояб. 2012 г., 0:49:13

Я использую эту функцию:

функция тест(){
 локальная переменная="привет"
ПС1="\у\$$ВАР"
}

Выход я пытаюсь получить от функции Джоном$Здравствуйте.

Но что меня просто Джон.

Если я добавить пробел перед $ВАР, то я делаю, вам близко то, что я хочу - но я не хочу, там достаточно места.

Можно ли делать то, что я хочу, не имея такого пространства?

+598
Srj4654 17 июл. 2014 г., 11:21:07
Ильшат@ЛПТ:~$ судо apt-получить установку синаптической
Чтение списков пакетов... готово
Построение дерева зависимостей 
Чтение информации о состоянии... готово
Пакет синаптической не доступен, но ссылается на другой пакет.
Это может означать, что пакет отсутствует, не используется, или
доступен только из другого источника

Е: пакет ‘синапса’ нет кандидата монтаж 
  • Я пробовал делать команду sudo apt-получить обновление , но это не работает.
+533
trpride 20 июн. 2015 г., 12:44:14

Это приложение предоставляет индикаторы для Qt-приложений, которые используют лотке (как Skype и VLC).

+479
Ilya Levchenko 12 авг. 2015 г., 1:03:17

Я только что обновил до Ubuntu 11.04 и я решил дать свой новый музыкальный плеер по умолчанию идти. У меня есть моя музыка в папку $дома/музыка, и я использовал в Rhythmbox. Баньши плеер имеет удобный товар на импорт, предполагая, что его может тянуть через Rhythmbox. Однако, когда я делаю это, он приходит с ошибками для всех бар пара альбомов, которые я купил через Amazon (МР3).

Любая идея, что я делаю неправильно? Есть ошибки за все треки, которые не засосет, предполагая, что его правильно прочитать список файлов. Я также попытался импортировать каталог с теми же результатами.

Сообщение об ошибке для каждого трека 'невозможно импортировать песни'.

Я сначала думал, что возможно это была проблема кодека, потому что я только что обновил и предположительно кодеки мне нужны уже не были в списке источников. Я нашел и установил их и нашли все другие способы игра может заниматься музыкой там.

Затем я подключил к моему серверу daapd и был в состоянии играть музыку на Банши оттуда. Это фактически та же музыка, так что я теперь думаю, это не проблема кодека.

+460
beatboxerMX 16 апр. 2011 г., 21:46:00

Я снял сегодня с PulseAudio, потому что Розеттский камень возникали конфликты идентификации микрофон, который как бы делает его бесполезным для меня, чтобы выучить новый язык. Дело в том, Alsamixer, похоже, облажался, так что я не очень знаком, на котором файл конфигурации мне нужно подправить, чтобы все использовать системе alsamixer (на самом деле он делает... но проблема вот в чем ошибка)

$ alsamixer 
Алса Либ пульс.с:229:(pulse_connect) с PulseAudio: не удается подключиться: подключение отказался

не удается открыть микшер: соединение отклонено

Мог ли кто-нибудь просветить меня на какой конфигурационный файл я должен изменить?

+417
keyur savaliya 9 июн. 2019 г., 2:04:22

Я создал загрузочную флэшку с помощью универсального USB установщик 1.9.0.9 и попытался загрузки с USB на ноутбуке с чистым жестким диском. Я продолжаю получать сообщение

Не может найти образ ядра: vesamenu.с32.

Я нашел файл на USB, что я делаю не так?

+394
Sid 10 окт. 2017 г., 3:28:31

Наглость является полнофункциональный звуковой редактор, доступный в Центре приложений для Ubuntu.

+391
probiotic 16 авг. 2018 г., 16:01:50

Если вы все еще не можете установить Убунту, сначала отключить Защитник Windows и попытайтесь установить. Вы можете легко установить без каких-либо окно сообщения.

+384
Ash 44 25 мая 2014 г., 0:17:31

я пытался скачать программе XAMPP, распакуйте его в /opt/lampp и запуск

судо ./светильник старт

но я получаю этот выход:

Запускаю XAMPP для Linux 1.7.7...
Программе XAMPP: другую программу веб-сервер уже запущен.
Программе XAMPP: начиная с MySQL...
Программе XAMPP: не запуска MySQL!
Александр Боровой полный видеокурс: программе XAMPP-службу proftpd уже выполняется.
XAMPP для Linux начинался.

так я открыл Synaptic и я установили сервер MySQL.

теперь у меня есть 2 проблемы, если я перезагрузки моего Ubuntu 10.10:

  1. каждый раз, когда я перезагрузки моя Ubuntu мне придется перепечатывать

    суда /и т. д./init.д/MySQL не остановить

  2. если после остановки демона MySQL я возобновить lampp я получаю то же сообщение: программе XAMPP: не запуска MySQL!

в /var/журнал/в MySQL.подстраховаться и /VAR/журнал/в MySQL.журнал пусты..

+382
Victor2708 15 июн. 2015 г., 22:34:23

Согласно Руководству по grub, первая нота-это "темп", а каждая следующая пара чисел являются длительность и высоту.

Высота В Гц, поэтому для того, чтобы играть красиво звучащие ноты (что созвучно), вам потребуется частот нот в равной западной шкале темперамента:

http://pastebin.com/rJY30FmM

Кстати, вот что я придумал после написания и через Java-код, я вставил:

GRUB_INIT_TUNE="480 220 1 277 1 330 1 440 1 185 1 220 1 277 1 370 1 294 1 370 1 440 1 587 1 330 1 415 1 494 1 659 1"

Это играет 4-Примечание арпеджио а, F#м D, Е.

+331
user71128 14 авг. 2013 г., 18:52:14

Узнал, что вы можете сделать судо команду killall х

и это, кажется, работает для меня!

+327
Satuhon 10 янв. 2011 г., 20:41:53

У меня была такая же проблема с 12.10 по nginx и Х соединения. Я думаю, что происходит заключается в том, что у вас нет супер на клавиатуре и потом она упала, так что супер+д ярлыка становится просто "Д".

Открыть интерфейсом dconf-редактор и перейдите к орг.гном.столе.Сус.хоткеев

Вы должны увидеть список всех горячих клавиш в GNOME. Я изменил все вхождения <супер> в <основной> (который является КМД-ключ на Mac-клавиатуре) и избавился от проблемы.

+299
Kenzer 30 окт. 2014 г., 13:07:20

Можно ли ставить окна кнопки на верхней панели корицы, как в единстве?

+258
jojo osinga 26 окт. 2017 г., 14:06:39

mpg123 Install mpg123

mpg123 - быстрый, бесплатный и консольный mpeg аудио проигрыватель программное обеспечение для операционных систем UNIX и Linux. mpg123 был портирован на Windows платформа, используя Cygwin и MinGW. Он поддерживает MPEG-1 и -2, слои 1, 2 и 3. Своя самая общяя польза для воспроизведения MP3 файлов. Он также поставляется как плагин Winamp.

im1

+236
Anshuman 9 апр. 2011 г., 13:31:26

Я просто скачал Ubuntu телефон SDK и Qt Творца, согласно инструкции.

Когда я запущу QTCreator, я получаю экран, как показано на рисунке

http://i.imgur.com/HrgO1su.png?1

Если я игнорирую это сообщение и нажмите Продолжить, нет никаких шаблонов для создания мобильного приложения, как указано в учебнике, по которому я иду.


Я попытался установить qt5-по умолчанию и qtchooser - проблема сохраняется. Вот сообщение об ошибке

Не может загрузить плагин, потому что зависимость не удалось загрузить: RemoteLinux(2.6.82) 
Причина: плагин не может загрузить, потому что зависимость не удалось загрузить: QtSupport(2.6.82) 
Причина: плагин не может загрузить, потому что зависимость не удалось загрузить: ProjectExplorer(2.6.82) 
Причина: файл /usr/lib в/для i386-линукс-дистрибутив GNU/qtcreator/Плагины/QtProject/libProjectExplorer.так: 
Не может загрузить библиотеку /usr/lib в/для i386-линукс-дистрибутив GNU/qtcreator/Плагины/QtProject/libProjectExplorer.так: 
(libQt5Declarative.так.5: не удается открыть общие объект файл: нет такого файла или каталога)
+187
brainray 12 июл. 2015 г., 8:47:56

Проверить С он, это идеальный АЭС замены для Linux. Вы можете делать то, что плюс вы можете использовать regex.

+152
Sadhana 8 окт. 2011 г., 3:49:46

На Emacs dataSource может быть найден на исходный код браузера. К сожалению, там не последняя версия (я работаю над этим) можно скачать здесь , нажав на "скачать" ссылка.

Это должно работать на любой версии Emacs, независимо от версии Ubuntu вы используете.

Затем этот файл может быть использован в Emacs путем добавления этой строки:

загрузить файл "/путь/к/файлу/дух времени.Эль"

для вашего .файл Emacs.

+105
PrisaCar 17 июн. 2010 г., 12:10:22

Если вы идете в вики Jmol,в http://wiki.jmol.org есть раздел под названием "установка Jmol" с инструкциями.

+68
Ben Fisher 11 февр. 2017 г., 2:05:16

Показать вопросы с тегом